Talk:Building FlightGear - Windows

From FlightGear wiki
Jump to navigation Jump to search

When I followed the instructions most things went smoothly, but I did encounter a few wrinkles:

SimGear -------------

When I attempted to build SimGear, I got a bunch of errors. After flailing around quite a bit, I tried checking out the version of SimGear that was active at the time the instructions were written, and the errors were pretty much gone (more on the pretty much below).

To do this, you'll need to do an update-by-date, probably from the command line (I could not figure out how to do it within Eclipse, which is what I generally use for my repository interaction): cvs -d update -D"2009-08-23" This will replace the Head version that you checked out with the version from 8/23.

This is likely to be an ongoing problem, since I think SimGear is *not* generally developed in Windows, so any Windows-compatibility is likely to be rather sporadic.

That still left a minor linking problem; I may have messed up the set-up a bit, but for some reason SimGear couldn't find jerror.h or jpeglib.h. I substituted the full path in the #include, since I really just wanted to get the darned thing to compile - and that did the trick.

FlightGear ------------

After various struggling, I wound up checking out the older date-based version (8/23/09) for this as well. I know that's not much help for people who truly need the latest and greatest . . . but I couldn't get the latest and greatest to work.

With the version from 8/23, things worked beautifully without a bunch of mucking around - just just a couple exceptions.

I had a few path problems with "boost". I got an extra layer of stuff when I unzipped boost_1_39_0; I had to take the nested boost directory and move it up a level before things were happy. Depending on the way you read the instructions this might be implied, but I completely missed the step.

It couldn't find sg.lib; I had to add ;..\..\..\..\plib to the end of the "Additional Library Directories" in the linker section of the FlightGear project properties.

And the compiled version of plib that I had downloaded ([1]) did not seem to be quite up-to-date enough - I got a bunch of linking problems. The other pre-compiled link supplied no longer had any pre-compiled goodies on the other end, so I had to follow the directions for retrieving and compiling plib - but those directions worked beautifully first try :)

Once I got that fixed, everything was happy.

Below are some of my notes from when I was trying to do the most up-to-date version. Some of them might also be handy for problems with the 8/23 version (since some of those changes may have actually impacted my reverted versino).

Many of the projects couldn't find plib. I just added the plib directory to the end of the include list of all my projects (right-click the project, go to properties, select C/C++, and add ;..\..\..\..\plib to the end of the "Additional Include Directories" field.

Some things also complained about the absence of GL/glut.h (get from [2]; download, extract to your base FlightGear directory with everything else, rename GL).


Erg. I was stepping through the various FlightGear issues, but now they are turning into the weird/hard-to-resolve sorts of things that I was getting with SimGear. I went ahead and switched my FlightGear download to be from 8/23 as well

With those few caveats, the instructions worked beautifully - thank you for putting them together! Considering how long things took even so, I hate to think how long I would have been at it without them.

-- Annaka

Updating the article

Due to the migration to Git, shouldn't the article be updated a bit? I already updated section CVS to reflect the current host for FlightGear's source code, so why not everything else that refers to CVS, excluding the header as that was already updated to reflect that? --Quadunit404 02:15, 3 July 2010 (UTC)

I plan to re-write the basic steps to build from git with MSVC90 very soon.. Since it took me quite a while to get it working using this document. I will stage my changes below this comment --Truthsolo 11:23, 1 August 2011 (EDT)