Hi fellow wiki editors!

To help newly registered users get more familiar with the wiki (and maybe older users too) there is now a {{Welcome to the wiki}} template. Have a look at it and feel free to add it to new users discussion pages (and perhaps your own).

I have tried to keep the template short, but meaningful. /Johan G

Fr/fg2blender

From FlightGear wiki
Jump to: navigation, search
FG2Blender
FG2Blender.jpg
Créateur(s) PAF team
FDM Inconnu
Etat Development
Développement
 Référentiel Le référentiel de développement du FG2Blender.

FG2Blender est un script python pour Blender qui permet de créer des animations, charger des fichiers XML, lire des FDM, créer des positions de caméra, exporter des morceaux de FDM... Il fonctionne à partir de Blender 2.6x

Ce script vise les contributeurs qui souhaitent faire des animations complexes (faire bouger un aileron selon un axe n'est pas une animation complexe). Aussi il peut vous aider à créer un environnement 3D complexe car il permet de charger un cockpit entier récursivement. Ainsi vous avez une vue globale du rendu final sans devoir lancer FlightGear pour vérifier chaque modification.


Téléchargements & Installation

Le script est disponible ici : https://gitorious.org/paf/fg2blender?p=paf:fg2blender.git;a=summary (Script non stable, en cours de développement). Une fois téléchargé, il vous suffit de déposer le dossier fg2blender dans votre dossier script/addons/ de Blender.


Le menu FlightGear Tools Menu

FG2Blender : Flightgear Tools Menu

Le menu "Flightgear Tools Menu" est accessible à l'aide de la touche "f" dans la fenêtre 3D de Blender.

Insert Keyframe Rotate
Insert une keyframe pour les animations de type "rotate". Pour l'utiliser, il faut sélectionner une armature créée avec l'item "Armatures > Create Rotation".
Insert Keyframe Translate
Insert une keyframe pour les animations de type "rotate". Pour l'utiliser, il faut sélectionner une armature créée avec l'item "Armatures>Create Translate".
Import (.xml)
Importe un fichier d'animation XML.
Creation animations
Crée la visualisation des animations. Pour l'utiliser, il faut avoir importé un fichier d'animation XML avec l'item "Import (.xml)".
Edge Split
Applique un "modifier" de type edge-split sur l'ensemble des objets sélectionnés.
Select property
Sélectionne un ensemble d'objets et d'armatures liés à l'objet actif. Par exemple; pour sélectionner un train d'atterrissage (armature + mesh), on sélectionne une partie. Puis avec l'item "Select roperty", on sélectionne l'ensemble. Puis avec CTRL+I (inversion sélection) et H(hide cache). On ne voit finalement que le train d'atterrissage. Cela peut être très utile lorsque l'animation est cachée par d'autre maillage.
Time x2
Augmente la vitesse de visualisation des animations par 2 (à utiliser après avoir créé la visualisation des animations).
Time x0.5
Diminue la vitesse de visualisation des animations par 2 (à utiliser après avoir créé la visualisation des animations).
Copy blender name to ac name
Recopie le nom Blender dans l'onglet FlightGear "ac name" un objet maillage (mesh). Lorsque l'on importe un avion, ce champ est déjà rempli, mais lorsque l'on crée un objet ce champ est vide. Lorsque l'on fait de la modélisation, on est très concentré sur le maillage et pas forcément sur le script.
Copy ac file (active->selects)
Permet de faire cette recopie en bloc sur une sélection.
Armatures > Create Rotation
Armatures > Create Translate
Armatures > Transfom to rotate
Armatures > Transform to translate
Armatures > Select Property
Sélection uniquement sur les armatures. Sélectionne toutes les armatures avec une même property flightgear.
Armatures > Copy xml file (active->selects)
Armatures > Copy property (active->selects)
Armatures > Reset Rotate
Armatures > Init Rotate
Armatures > Save Keyframe and Reset
Sauvegarde une(des) animation(s) et la(les) réinitialise à zéro (plus de translation, ou plus de rotation).
Armatures > Restore Keyframe
Restaure l'(les) animation(s) sauvegardée
Armatures > Save Parent and Reset
Armatures > Restore Parent
Unwrap 4 faces
Dépliage 4 faces
Manual
Ouvre votre navigateur web pour consulter le manuel ici présent.


La fenêtre Flightgear Object

FG2Blender : Flightgear Object

Panneau visible dans l'onglet "Object" de Blender après avoir sélectionné un objet 3D

Mesh Name
Nom de l'objet 3D tel qu'il est dans le fichier AC3D et qui sera utilisé lors de l'export. Cela évite les noms du genre vitre.001, vitre.002, vitre.003... lorsque l'on importe plusieurs fichiers AC3D qui contiennent des objets du même nom.
Filename
Emplacement du fichier AC3D auquel appartient l'objet 3D. C'est aussi ce fichier qui sera utilisé lors de l'export.
Save ac file
Exporte tous les objets 3D appartenant au fichier AC3D situé dans le champ "Filename".
Parent
Armature parent dont dépend l'objet. Cliquez sur "Select" afin de travailler sur l'armature qui régie cet objet. (Uniquement visible si une animation est déjà associée à l'objet).


La fenêtre Flightgear Animation

FG2Blender : Flightgear Animation
Family
Famille de propriété associée à l'animation.
Node
Nom de la propriété qui doit être utilisée (Visible uniquement si Family est différent de "custom").
Property
Chemin complet de la propriété qui doit être utilisée.
Value
Dans le cas d'une propriété numérotée, c'est la valeur du numéro de la propriété. Par exemple, si value = 0, la propriété sera gear/gear[0]/rollspeed-ms, si value = 3, la propriété sera gear/gear[3]/rollspeed-ms
Include disk file
to Disc
xml File
Emplacement du fichier XML auquel appartient l'objet 3D.
Write File
Exporte toutes les animations appartenant au fichier XML situé dans le champ "xml file" (Les données ne sont pas écrites directement dans le fichier XML, elles sont accessibles dans l'environnement "Scripting").
Type
Type de l'animation
factor
Valeur de la balise <factor>
Time
Min
Valeur minimum que peut prendre la propriété dans FlightGear.
Max
Valeur maximum que peut prendre la propriété dans FlightGear.
Child(s) object(s)
Liste des objets et armatures qui dépendent de cette armature.
Parent
Armature dont dépend l'armature actuellement sélectionnée.

Liens

Développement : http://equipe-flightgear.forumactif.com/t987-script-flightgear

Dépôt GIT : https://gitorious.org/paf/fg2blender?p=paf:fg2blender.git;a=summary

Tutoriel : http://equipe-flightgear.forumactif.com/t1019-script-d-animation-blender

Exemple : http://clemaez.fr/flightgear/fg2blender_example.tar.gz