Hi fellow wiki editors!

To help newly registered users get more familiar with the wiki (and maybe older users too) there is now a {{Welcome to the wiki}} template. Have a look at it and feel free to add it to new users discussion pages (and perhaps your own).

I have tried to keep the template short, but meaningful. /Johan G

TaxiDraw

From FlightGear wiki
Jump to: navigation, search
TaxiDraw
Taxi scheme of Gary/Chicago International Airport (KGYY) in TaxiDraw.
Taxi scheme of Gary/Chicago International Airport (KGYY) in TaxiDraw.
Developed by Ralf Gerlich, David Luff, Durk Talsma
Initial release 2005 (?)
OS Windows, GNU/Linux, MacOS X, IRIX and FreeBSD
License GNU General Public License
Website


TaxiDraw is a (free) taxiway editor for FlightGear and previously X-Plane, licensed under the GNU GPL. It is cross-platform, known to work on Windows, GNU/Linux, MacOS X, IRIX and FreeBSD.

Note  TaxiDraw supports apt.dat formats up to 810. Future scenery builds of FlightGear will make use of the newer 850 format, which is also used by X-Plane. For this newer format, WorldEditor should be used.

Any further airport updates done in TaxiDraw will not be used.

Installing TaxiDraw

On Windows, simply unzip the downloaded zip archive to a suitable location. On Linux, the source will need compiling - the only dependency is on wxWidgets, version wxGTK-2.6.x is known to work. If using packages make sure you install the -dev package if required to get the headers.
Ubuntu and debian users can install the cvs version see: Ubuntu fg tools.

Binaries (ready-to-use) of TaxiDraw can be downloaded:

  • Windows (Tested on Windows 10).
  • Mac (Taxidraw.cvs-bin-....tgz)

Downloading the raw data

TaxiDraw needs to be able to find the default airport data file in order to load the default airport layout prior to modification. The default airport data was originally available in two formats, X-Plane and FlightGear, but only X-Plane format is used now. TaxiDraw currently understands both formats, but support for the old FlightGear format should be considered deprecated, and will eventually be dropped. You can download the latest airport data from the this link maintained by Martin Spott, or use the airport data shipped with FlightGear in $FG_ROOT/data/airports. Wherever you source the data, it will need to be unzipped before TaxiDraw can use it. Place the apt.dat file somewhere on your system, and remember where it is, since it is necessary to tell TaxiDraw where to find it.

Configuring TaxiDraw to use the raw data

Once at least one set of raw data has been downloaded, it is necessary to configure TaxiDraw to find and use the data. If this is the first time you have run this version of TaxiDraw you will be reminded to do this at startup. Go to the Airport->Raw Data Options menu entry. This brings up a dialog that allows you to enter the location of the X-Plane and/or FlightGear data, and to specify which is the default data to use. You can browse for the data using the 'choose...' button. Just remember that the data must be unzipped for TaxiDraw to be able to use it. Any time that you wish to change the default data location or type, you can simply re-visit this dialog.

Testing that TaxiDraw works OK

KSFO in TaxiDraw

To check that TaxiDraw works OK with the data you have configured as above, press Ctrl+N (or File->New) and enter "KSFO" (without the quotes) in the airport-selector dialog box that comes up. You should see the wait cursor for a few moments as it reads the file, and then the KSFO runways and taxiways should be displayed as shown right of this text. If you don't see this, then you need to make sure that TaxiDraw is properly configured to find some valid, unzipped, data before proceeding.

Using TaxiDraw

Background image

A background image can be used to easily draw an airport layout; all you need to do is overlay the image with runways/taxiways. In order to keep the right coordinates, it is required to calibrate the image.

  1. Load a background image via View > Load Background Image.
  2. Uncheck Right mouseclick > Lock Layers > Background Images.
  3. You can now reach the calibration menu via Right mouseclick > Calibration and move/scale the image with the mouse.

Related content

External Links