Hi fellow wiki editors!

To help newly registered users get more familiar with the wiki (and maybe older users too) there is now a {{Welcome to the wiki}} template. Have a look at it and feel free to add it to new users discussion pages (and perhaps your own).

I have tried to keep the template short, but meaningful. /Johan G

Talk:FlightGear Version Check

From FlightGear wiki
Revision as of 03:47, 6 August 2017 by Hooray (Talk | contribs) (The FlightGear executable now checks this)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

features

JA37

We should grep through $FG_ADDON to see if there are any other aircraft processing /sim/version in *.nas files, and check what is done/needed there. So far, the JA37 has the best-developed system in place, and it does not just silently fail/exit, but will do dynamic-feature scaling by disabling stuff, i.e. true backward compatibility. So that seems to be much better in comparison. It would only need to be generalized, e.g. to support SGConditions via props.nas and custom message/code blocks to enable/disable features

terminating

should take into account the aircraft centre and in-sim switching[1]

disable version-check

should introduce a property to disable the whole thing for power users using a prop switch

modal error dialog

should we disable/hide the menubar and use Draw masks to hide everything else?

localized

should use $FG_ROOT/Translations as a workaround for non-English errors messages

GUI independent

should work independently of the used frontend (PUI, Phi, Canvas, Qt)[2]

logprint

should be used to ensure that everything shows up in the log file

properties

we could make this much more generic by allowing arbitrary properties to be checked and warnings/errors to be shown, which would allow aircraft developers to provide custom messages to clarify if/how an aircraft is going to be affected by mismatching versions--Hooray (talk) 08:33, 17 November 2015 (EST)

conditions

props.nas

References

The FlightGear executable now checks this

This have been added to FlightGear itself by James Turner Jun 21, 2017. FlightGear now checks the property /sim/minimum-fg-version (string) against the FlightGear version and will show some error messages if the aircraft is too new. See this commit.

I know, see the last change I made at [1]. I don't know how this relates to the other ideas originally discussed on the forum though, and if this also works properly for the non-Qt build, too ? In general, it seems that more and more stuff is added that only works for the Qt-enabled version, whereas the approach used in this article is agnostic to the type of UI in use. --Hooray (talk) 03:47, 6 August 2017 (EDT)