Hi fellow wiki editors!

To help newly registered users get more familiar with the wiki (and maybe older users too) there is now a {{Welcome to the wiki}} template. Have a look at it and feel free to add it to new users discussion pages (and perhaps your own).

I have tried to keep the template short, but meaningful. /Johan G

Difference between revisions of "Talk:Building FlightGear - Devuan"

From FlightGear wiki
Jump to: navigation, search
(Suggestions: missing packages + why build plib?)
 
Line 7: Line 7:
 
* Current FG from next requires these two packages when building with Qt support: qtdeclarative5-private-dev and qml-module-qtquick2 (since [https://sourceforge.net/p/flightgear/flightgear/ci/3a8d3506d651b770e3173841a034e6203528f465/ FG commit 3a8d350], committed on 2017-09-26).
 
* Current FG from next requires these two packages when building with Qt support: qtdeclarative5-private-dev and qml-module-qtquick2 (since [https://sourceforge.net/p/flightgear/flightgear/ci/3a8d3506d651b770e3173841a034e6203528f465/ FG commit 3a8d350], committed on 2017-09-26).
 
--[[User:Rominet|Rominet]] ([[User talk:Rominet|talk]]) 18:31, 3 October 2017 (EDT)
 
--[[User:Rominet|Rominet]] ([[User talk:Rominet|talk]]) 18:31, 3 October 2017 (EDT)
 +
 +
: Oy!
 +
: a) yw
 +
: b) TBH I am not certain whether the plib step is required anymore, will look into that for the next update (for which I hope to have some spare time in the upcoming days). Last time I've checked it was required since Melchior's commits never went into a release and hence never reached Debian.
 +
: c) Thanks for reporting the newly required packages, saves myself some research!
 +
: --[[User:Flughund|Flughund]] ([[User talk:Flughund|talk]]) 22:27, 3 October 2017 (EDT)

Revision as of 22:27, 3 October 2017

Hello,

I didn't try these instructions recently, but they proved very useful when I first built FG, so thanks for this!

Two remarks:

  • plib being dead upstream, what is the point of building it? I've always used the Debian one for this without any problem (well, actually a fixed local version for joystick deadband management; sid now has the fix at last, but not stretch, unfortunately).
  • Current FG from next requires these two packages when building with Qt support: qtdeclarative5-private-dev and qml-module-qtquick2 (since FG commit 3a8d350, committed on 2017-09-26).

--Rominet (talk) 18:31, 3 October 2017 (EDT)

Oy!
a) yw
b) TBH I am not certain whether the plib step is required anymore, will look into that for the next update (for which I hope to have some spare time in the upcoming days). Last time I've checked it was required since Melchior's commits never went into a release and hence never reached Debian.
c) Thanks for reporting the newly required packages, saves myself some research!
--Flughund (talk) 22:27, 3 October 2017 (EDT)