Hi fellow wiki editors!

To help newly registered users get more familiar with the wiki (and maybe older users too) there is now a {{Welcome to the wiki}} template. Have a look at it and feel free to add it to new users discussion pages (and perhaps your own).

I have tried to keep the template short, but meaningful. /Johan G

Difference between revisions of "Howto:Create custom terrain"

From FlightGear wiki
Jump to: navigation, search
m
m
Line 75: Line 75:
 
* '''Towns''' are much smaller than urban areas and you may not be able to pick up any distinct patterns.  
 
* '''Towns''' are much smaller than urban areas and you may not be able to pick up any distinct patterns.  
 
* '''Industrial Areas''' should be digitized if you know where the areas are. They are usually characterized by large, boxy buildings on the outskirts of urban areas, though this obviously varies by city!
 
* '''Industrial Areas''' should be digitized if you know where the areas are. They are usually characterized by large, boxy buildings on the outskirts of urban areas, though this obviously varies by city!
 +
 +
===Digitizing tips and tricks===
 +
* You can change the color of the shapefile by clicking on it in the left display toolbar. It usually is a good idea to set the transparency of the layer you are digitizing to between 50 and 75 percent so you can still see what you have digitized underneath the polygon. This can help you fix errors as they are introduced.
 +
* If you have a large feature to digitize, such as a forest, you don't have to digitize all of it at one time! Instead, you can create small polygons labeled as 'forest' next to each other. Merging them into one polygon is pretty straight forward:
 +
*# Go into edit mode and pick the Select feature (<tt>View > Select Features</tt>).
 +
*# Click on the first polygon and then on the other(s), while holding the Ctrl-key. The selected polygons should turn yellow.
 +
*# Click the Merge selected features icon (or <tt>Edit > Merge selected features</tt>).
 +
*# Check whether the classes correspondend (if not, you might be mixing two different areas!) and click OK.
 +
* If there is a lake (or other area) in the middle of a forest you have already digitized, you can use the QGIS ring feature to cut a hole in the polygon. You can then fill in the hole by creating another polygon.
 +
 +
===Eporting the shapefile===
 +
In order to turn the landclass into scenery we have to split it into seperate shapefiles for each landclass.
 +
 +
# Open the Attribute table (<tt>Layer > Open Attribute table</tt>).
 +
# Type "Sand" (or another class) into the search box and press the Search button. This will select all polygons that have the Sand class assigned.
 +
# Go to <tt>Layer > Save Selection as Shapefile</tt> and save the sand shapefile somewhere on your computer.
 +
# Do the same for all other classes.
 +
# To make the difference between land and sea (landmass) we save the entiry shapefile (<tt>Layer > Save as Shapefile</tt>).
  
 
We have been working with UTM coordinates so far. To generate scenery that can be used in FlightGear we need to convert the shapefiles to the latitude/longitude format.
 
We have been working with UTM coordinates so far. To generate scenery that can be used in FlightGear we need to convert the shapefiles to the latitude/longitude format.
Line 83: Line 101:
 
*# Look up your projects UTM coordinate through [http://upload.wikimedia.org/wikipedia/commons/e/ed/Utm-zones.jpg this image]. For Texel this is 31U, so we choose UTM31 in fGIS. If your project is located south of the equator, you tick the S box.
 
*# Look up your projects UTM coordinate through [http://upload.wikimedia.org/wikipedia/commons/e/ed/Utm-zones.jpg this image]. For Texel this is 31U, so we choose UTM31 in fGIS. If your project is located south of the equator, you tick the S box.
 
*# Set the Output Shapefile Project to <tt>Lat./Lon.</tt>.
 
*# Set the Output Shapefile Project to <tt>Lat./Lon.</tt>.
*# Now click the Input Shapefile button to load the shapefile that we exported from qGIS.
+
*# Now click the Input Shapefile button to load the shapefile that we exported from QGIS.
 
*# Using the Output Shapefile button we decide where we want to store the lat/lon shapefile. This has to be a non-exisiting file, so remove before updating.
 
*# Using the Output Shapefile button we decide where we want to store the lat/lon shapefile. This has to be a non-exisiting file, so remove before updating.
 
*# Click the Convert button.
 
*# Click the Convert button.
 +
*# Repeat this process for all shapefiles.
 +
 +
These shapefiles can be send to the custom scenery database in the name of papillon81 and statto (contact through IRC or Forum).
  
 
===Generating scenery===
 
===Generating scenery===

Revision as of 16:40, 15 November 2009

WIP.png Work in progress
This article or section will be worked on in the upcoming hours or days.
See history for the latest developments.

Look here an example of the achievable result.

Let's take a look at the Finistère in Brittany, Western France: if you click [1], you will quickly see and understand how the Finistère county is know of FlightGear. Some towns/city (red), a few forests (green), etc. Overall, it is not a very good resolution: a lot of angles, the detail level is not that good, some towns are missing. If you want a better definition on ground, there is some work to be done! The goal being to obtain something like this:

  1. Berlin
  2. Bodensee surroundings
  3. Oshkosh surroundings
  4. Carribs

You will immediately notice the improvement to the ground. When flying, the difference is huge. Moreover, this enables the autogeneration of cities, trees, farmland, and so on.

Downloading the Landsat pictures

Landsat Map Search
Preview and download Landsat image

Browse to the Earth Science Data Interface interface to grab your Landsat data.

  1. Click Map Search.
  2. Tick the ETM+ box (left column).
  3. Click on Update Map on the right bottom of the map.
  4. Click on the Place tab on the upper side of the map, in order to do a search by place, or you can do a search by latitude/longitude.
  5. In the Place field, type Amsterdam, Netherlands for instance.
  6. Now click the button with the mouse and the small + sign. This will allow you to select image tiles. Select all images that cover your area of interest, in our example this is just one image.
  7. Click on Preview and download. This bring you to a selection page were you can choose what image you want to download. It is likely that there are pictures available from different dates for your area. Picking the most recent one is best, for known reasons.
  8. Clicking the ID will not bring you directly to the download page, first you have to click the Download button.
  9. Download the _nn80.tif.gz file (if this is not available, try an older image).
  10. Uncompress the .tif.gz files in the directory of your choice.

Working with QGIS

QGIS with the TIFF image.
Creating the class column.
Toggle editing.
Tracing the small island.
The finished small island polygon.

Using a GIS software gives you the opportunity to realize a full range of interesting operations: modification of VMAP data, updates on the ground classification, etc...

  • If you run GNU/Linux, you can install QGIS with your usual package repositery manager; see here. The process is easy and not described here, but it is one the QGIS website.
  • If you are running Windows, download QGIS from here (Windows - Standalone).
  1. Launch QGIS.
  2. Click on Layer > Add a Raster layer.
  3. Modify the filter to search for *.tif files.
  4. Add the TIFF file you have just downloaded.
  5. Click on Layer > Add a new vector layer or on the corresponding icon. A dialog should pop up.
    • Make sure the file type is an ESRI Shapefile.
    • Make sure the vector type is set to polygon.
    • You need to create a data column for this layer. Create a column called 'class'. Make sure it is a string column. Add it to the attribute list by selecting the Add Values Manually button. The 'OK' button should now be available for you to select. Select 'OK'.
    • There should be a dialog box prompting you to save your vector layer. Save it in your scenery directory with your GeoTIFF. (This is not required but significantly helps organization.)
    • A projection box should pop up. Select 'WGS 1984'. After all, that is the globe model used in FlightGear.
  6. Your vector layer should appear in the left-hand toolbar. You are ready to begin digitizing.
  7. Select the newly created layer in the layer list, toggle editing (Layer > Toggle Editing) and finally select Capture Polygon from the same menu/toolbar.
  8. With your mouse, left-click on a point at the southwestern edge of the small island.
  9. We now want to trace the outline of the island. Move your mouse to another point below the first point and click it again. Your mouse should show a red line. The points should not be redundant - for instance, as long as the line between two points is straight, there is no need for another point in between the two.
  10. You will want to digitize features in a circular manner to avoid problems. You can always go back and add points later. With this in mind, move your mouse to a third point on the island. A small triangle should form, representing the polygon which would result if you decided you were done with the polygon.
  11. Continue outlining the island by clicking along its shoreline. When you are on your last point, instead of left-clicking, right-click. QGIS will finish the polygon.
  12. A dialog box will pop up, asking you to type in the value for 'class'. Since this is a shoal, existing of just sand, type in Sand. This step is important - it is how you know what each polygon should be mapped to in our finished scenery. A list of "allowed" materials (and thus classes) is available here.

Continue with tracing all shapes on the island: towns, industrial areas, grass, farmland etc.

It is imporant to enable "snaping" now. We don't want small holes in our scenery, nor do we want overlapping polygons. Snapping adjusts each point as you go by - you will miss occasionally and have to correct it - so you don't have to worry about lining the polygons up precisely.

  1. Open Settings > Project Properties and click the Snapping options... button.
  2. Click the tickbox(es) in front of your layer(s) and set Tolerance to 20 (map units). A smaller tolerance will make it easier to work with very small and detailed layers.
  3. Click OK to save the snapping options.

Distinguishing Land Class Types from LANDSAT data

For people who have not worked with satellite imagery before, it may be difficult to figure out what certain areas of land are. Of course you need Google Maps or similair software running, to see what is what on the black/white image, but most areas can be recognised without. Here is a list which may help you:

  • Water is always black or very close to being black. However, shadows from clouds can also appear black on your image. If your image has clouds, use caution!
  • Forests are also dark grey.
  • Scrub Cover is like a forest, but lighter in color since the forest consists of shrubs, not trees.
  • Crops can be a wide variety of different colors, but are easily distinguishable by their field-like patterns. You have your choice between dry crops, mixed crops and irrigated crops - take a look at the corresponding texture to figure out which crop style best suits your area.
  • Golf Courses should be digitized as a class even though we do not have a texture for them yet. They should be conspicuous by their pattern and their bright pixels.
  • Urban Areas should have some semblance of a pattern to them. Pixels can vary from darkness to lightness.
  • Towns are much smaller than urban areas and you may not be able to pick up any distinct patterns.
  • Industrial Areas should be digitized if you know where the areas are. They are usually characterized by large, boxy buildings on the outskirts of urban areas, though this obviously varies by city!

Digitizing tips and tricks

  • You can change the color of the shapefile by clicking on it in the left display toolbar. It usually is a good idea to set the transparency of the layer you are digitizing to between 50 and 75 percent so you can still see what you have digitized underneath the polygon. This can help you fix errors as they are introduced.
  • If you have a large feature to digitize, such as a forest, you don't have to digitize all of it at one time! Instead, you can create small polygons labeled as 'forest' next to each other. Merging them into one polygon is pretty straight forward:
    1. Go into edit mode and pick the Select feature (View > Select Features).
    2. Click on the first polygon and then on the other(s), while holding the Ctrl-key. The selected polygons should turn yellow.
    3. Click the Merge selected features icon (or Edit > Merge selected features).
    4. Check whether the classes correspondend (if not, you might be mixing two different areas!) and click OK.
  • If there is a lake (or other area) in the middle of a forest you have already digitized, you can use the QGIS ring feature to cut a hole in the polygon. You can then fill in the hole by creating another polygon.

Eporting the shapefile

In order to turn the landclass into scenery we have to split it into seperate shapefiles for each landclass.

  1. Open the Attribute table (Layer > Open Attribute table).
  2. Type "Sand" (or another class) into the search box and press the Search button. This will select all polygons that have the Sand class assigned.
  3. Go to Layer > Save Selection as Shapefile and save the sand shapefile somewhere on your computer.
  4. Do the same for all other classes.
  5. To make the difference between land and sea (landmass) we save the entiry shapefile (Layer > Save as Shapefile).

We have been working with UTM coordinates so far. To generate scenery that can be used in FlightGear we need to convert the shapefiles to the latitude/longitude format.

  • Windows
    1. Download fGIS and install it as described.
    2. Open an empty project and visit Utilities > Shapefile Projection Utility.
    3. Look up your projects UTM coordinate through this image. For Texel this is 31U, so we choose UTM31 in fGIS. If your project is located south of the equator, you tick the S box.
    4. Set the Output Shapefile Project to Lat./Lon..
    5. Now click the Input Shapefile button to load the shapefile that we exported from QGIS.
    6. Using the Output Shapefile button we decide where we want to store the lat/lon shapefile. This has to be a non-exisiting file, so remove before updating.
    7. Click the Convert button.
    8. Repeat this process for all shapefiles.

These shapefiles can be send to the custom scenery database in the name of papillon81 and statto (contact through IRC or Forum).

Generating scenery

Please continue with TerraGear to generate the landclass into useable scenery.

External links