Difference between revisions of "Building FlightGear - Linux"

From FlightGear wiki
Jump to: navigation, search
(Instructions)
Line 1: Line 1:
 
== Requirements ==
 
== Requirements ==
 
*  C++ compiler
 
*  C++ compiler
* OpenGL support
+
* OpenGL support (until version 0.9.10 release sources, PLIB CVS branch)
 +
* OpenSceneGraph (cvs HEAD branch)
  
 
== Dependencies ==
 
== Dependencies ==
 
* pthreads
 
* pthreads
 
* (Free)GLUT or SDL
 
* (Free)GLUT or SDL
* [http://plib.sourceforge.net/ PLIB]
+
* [http://plib.sourceforge.net/ PLIB] (until version 0.9.10 release sources, PLIB CVS branch)
 
* [http://openal.org OpenAL and ALUT]
 
* [http://openal.org OpenAL and ALUT]
 
* [http://simgear.org SimGear]
 
* [http://simgear.org SimGear]

Revision as of 20:15, 3 November 2006

Requirements

  • C++ compiler
  • OpenGL support (until version 0.9.10 release sources, PLIB CVS branch)
  • OpenSceneGraph (cvs HEAD branch)

Dependencies

Optional Dependencies

Instructions

Tools

Free/Open Source

Free/Proprietary