Hi fellow wiki editors!

To help newly registered users get more familiar with the wiki (and maybe older users too) there is now a {{Welcome to the wiki}} template. Have a look at it and feel free to add it to new users discussion pages (and perhaps your own).

I have tried to keep the template short, but meaningful. /Johan G

Changes

Jump to: navigation, search

Fr/Foire aux questions

1,178 bytes added, 21:27, 3 October 2012
Pourquoi est-ce que FlightGear ne compile pas ?
{{main article|Building Flightgear}}
=== Pourquoi est-ce que FlightGear ne se compile pas ? ===
Well, that dependsles causes peuvent être vraiment très variées. First make sure you are using the appropriate En premier lieu soyez vraiment sur d'avoir les bonne versions of de FlightGear, [[SimGear]](par exemple FlightGear V2.9 avec simgear V2.9) autrement votre compilation à de grande chance de finir en erreur. Compiler demande beaucoup d'organisation et de rigueur, plibc'est un peu comme si l'on menait une enquête pour résoudre les dépendances, zlibpar exemple lors de la configuration de vos sources il vous faudra absolument éplucher scrupuleusement les logs et autres messages d'erreur afin de vous assurer que pour chaque code source il y ait les dépendances nécessaire d'installées(dans la version demandée). If any of the packages are out of sync with the others: La plupart du temps (notamment pour les utilisateurs linux) il vous faudra simplement utiliser votre gestionnaire de paquet(synaptic ou autre..) pour installer les dépendances manquante; si elles ne sont pas présente dans votre gestionnaire de paquet il vous faudra obligatoirement les compiler. Sans rigueur ca peut devenir très vite un véritable enfer: imaginez vous en train de compiler des dépendances de dépendances et puis après perdre le fil et ne plus se souvenir de ce que l'on devait compiler ensuite...: Pour commencer à compiler il vaut mieux utiliser un environnement linux(ou mac), à mon sens la compilation may fail. See also [[Building de FlightGear]]sous windows est vraiment réservée à des utilisateurs confirmés qui se sont déjà fait la main sous linux.
The FlightGear Downloads la page (httpde [[Portal://www.flightgear.org/Downloads/) Developer|téléchargement]] de Flightgear should tell you what versions you need if you are trying to compile the latest stable release. If you are using a development snapshot, make sure all three packages are up-to-date.
Also ensure that you have some implementation of OpenGL with glut support with the appropriate header files. Linux users with nVidia cards should make sure you have the latest drivers from nVidia. Other Linux users make sure you have Mesa3D (http://mesa3d.org/) and your X server installed correctly.
286
edits

Navigation menu